wordpress站内站固定连接静态化的问题 悬赏5元 已结束

621 次浏览

主站用的wordpress。又用WordPress做了个站内站,站内站做固定连接静态化后,站内战文章打开显示404页面,求助大神们如何解决!!!

用的云主机和宝塔Linux面板。

追加问题
    6 人参与回答
1元
获得赏金
崔家大院
崔家大院 · 网站诊断、建站、快速排名 qq:787808565
无量 等 1 人赞同该回答

固定链接导致页面404错误开始出现:

此时我们修改了固定链接之后,访问网站文章内页就会出现404错误,我们假如选择的是固定链接的“自定义结构”,就会在下方出现如下提示:

如果您的.htaccess文件可写,我们即会自动帮您完成,但其目前不可写,所以以下是您需要加入您的.htaccess文件中的mod_rewrite规则。点击文本框并按CTRL + a来全选。

如图:

我们在WordPress网站根目录新建.htaccess文件,然后将上方的代码全部复制到里面,并保存文件,然后修改apache服务器中的httpd.conf文件的这部分代码,如下:

<Directory "/var/www/html">

    Options Indexes FollowSymLinks

    //将AllowOverride None改为all

    AllowOverride all

    Require all granted

</Directory>

重启Apache服务器即可解决!


3元
获得赏金

重新生成一下试试

1元
获得赏金
高飞
高飞 · 素材火

伪静态规则没选对吧?

OSEO|冷风
OSEO|冷风 · 无一技之长,难显真善美

宝塔看一下伪静态规则



 WordPress 的固定连接   /%post_id%.html   设这个,  


施先生
施先生 · 资深的SEO/SEM工作者和管理者

可以试试3楼的方法

大水比
大水比 · 我学了假的seo,我是假seo界的扛把子。

你这个问题我遇见过了,Windows操作系统的主机都是这个德行,实现不了站内站静态化,linux系统的主机可以实现,如果你发现能实现了Windows系统站内站静态化的规则也跟我说一下。